Dash 2 firmware

Posts: 1
Joined: Thu Nov 02, 2017 4:38 pm

Dash 2 firmware

Postby Davidmmx » Thu Nov 02, 2017 4:46 pm

Where can I find old firmware? I had my dash 2 up and running good with firmware 9.1.0 and now I update it to the latest it doesn't work so good.

Posts: 60
Joined: Mon Oct 27, 2014 10:19 pm

Re: Dash 2 firmware

Postby peterguk » Fri Nov 03, 2017 9:02 pm

9.1.0 sounds old. I've been using 9.3.5 for ages.

Posts: 20
Joined: Sat Oct 15, 2011 7:05 pm
Location: Lancashire

Re: Dash 2 firmware

Postby sparkystav » Sun Nov 05, 2017 10:36 pm

I had the same issue.

Firmware 10 for the Dash2 didn’t work with pressure sensors from my Ecu.
Went back to 9.3.5 and it works.

You’ll find the older firmware in the “flash” folder in the c: program files folder for the race technology software.

Support (D)
Posts: 74
Joined: Mon Aug 17, 2015 9:36 am

Re: Dash 2 firmware

Postby Support (D) » Tue Nov 07, 2017 3:28 pm

Dear Customer(s),

We are currently working to fix the known issues with the new firmware / software for the DASH2.

In the meantime, firmware versions: 9.3.4 or 9.3.5 will work just fine (9.3.5 has the backlight on the dash continuously turned on).

Best regards,

Posts: 14
Joined: Mon Feb 18, 2013 9:03 pm
Location: Southend-On-Sea

Re: Dash 2 firmware

Postby GROPIUS » Mon Mar 11, 2019 9:09 am

Good morning,
I haven't been on here for a while.
Has this issue been solved?

I believe Firmware 10 is required to use the new set-up software?

Posts: 1
Joined: Sat Aug 10, 2019 12:23 pm

Re: Dash 2 firmware

Postby Bizz » Sat Aug 17, 2019 4:01 pm


No this hasn't been fixed. Been working through this for the last week with on the latest firmware and oil pressure sent from the ECU is still not reading.

My dash has now gone wrong following all the updates so sending back to RT on Monday for urgent repairs :-(

Return to “Installation problems”

Who is online

Users browsing this forum: No registered users and 4 guests