DL-1 Serial ECU Interface - Megasquirt?

cguenther
Posts: 36
Joined: Sun Jan 25, 2009 11:12 pm

Postby cguenther » Fri Apr 30, 2010 8:12 am

Hi,

i will be able to test the interface during the next weeks, will keep ypu informed.

best regards
carsten

WillM
Posts: 84
Joined: Wed Dec 27, 2006 11:00 pm

Postby WillM » Fri Apr 30, 2010 3:30 pm

Hello Carsten,

Thanks for the update. Which MegaSquirt version are you running?

Thanks again,

Will

cguenther
Posts: 36
Joined: Sun Jan 25, 2009 11:12 pm

Postby cguenther » Fri May 28, 2010 12:03 pm

Hi,

its an MSExtra-II. However, i received my VIDEO4-System in the meantime and i am still waiting for the in car tft-screen to complete the system. once this is here i will start to test.

best regards
carsten

olie05
Posts: 3
Joined: Wed Jun 30, 2010 7:08 pm

Postby olie05 » Tue Jul 06, 2010 1:04 am

I run megasquirt on a few vehicles. I would like to know if there's any progress on the interface.

Also, is this a rs232 interface or a can bus interface?

Support

Postby Support » Tue Jul 06, 2010 9:36 am

The interface is a serial RS232.

cguenther
Posts: 36
Joined: Sun Jan 25, 2009 11:12 pm

Postby cguenther » Fri Jul 30, 2010 10:19 pm

Hi,

did some initial testing today.

Issue 1: Car will not start if ECU-Adapter is connected. It somehow blocks the ECU from proper function.
Issue 2: Unable to receive Output from the ECU-Adapter. I have the ECU-Interface connected with 12V supply and the Null-Modem cable to the PC, but Monitor Lite does not see anything and there is nothing on the rs-232 when looking via hypeterm on it.

Ive recorded some RS-232-communication with the original MS2Extra/Megatune-Software. Is the EMail mhill@race... still correct?

If yes, let us get in touch again to sort out the problems.

best regards
Carsten

Support

Postby Support » Mon Aug 02, 2010 10:37 am

Martin (mhill(at)... ) is currently on holiday but is picking up emails every once in a while so send this over to him and we'll take it from there.

cguenther
Posts: 36
Joined: Sun Jan 25, 2009 11:12 pm

Postby cguenther » Mon Aug 02, 2010 12:03 pm

Hi Team,

mail to martin has just been sent. It includes a log from the original Software which covers a complete car off/start/run/car off cycle.

decoding of the bytes polled from the ecu should work, actually its a kind of "getting started" to milk the ecu.

from now on its no problem to immediately flash the ecu-interface and test a new firmware. please advise.

best regards
Carsten

cguenther
Posts: 36
Joined: Sun Jan 25, 2009 11:12 pm

Postby cguenther » Fri Aug 06, 2010 4:10 pm

Hi,

FYI: Martin got a complete set of megasquirt serial comms to find out whats going on.

best regards
carsten

olie05
Posts: 3
Joined: Wed Jun 30, 2010 7:08 pm

Postby olie05 » Mon Aug 16, 2010 6:41 pm

Will this work with the different serial baud rate of megasquirt I?

WillM
Posts: 84
Joined: Wed Dec 27, 2006 11:00 pm

Postby WillM » Mon Aug 16, 2010 9:46 pm

Nope.

At least it did not work for me.

I purchased a Serial ECU adapter to work with my MegaSquirt-I running the MS1-Extra ECU, and it did not work.

I have since changed ECU's and had my Serial ECU adapter re-flashed to work with the new ECU (Vi-PEC).

sturgeo
Posts: 2
Joined: Sun Feb 07, 2010 1:39 pm

Postby sturgeo » Thu Aug 19, 2010 7:21 pm

Anymore progress with this, we are running ms2 extra code version 3.0.3r on a few vehicles and want to get these data loggers and dashes.

cguenther
Posts: 36
Joined: Sun Jan 25, 2009 11:12 pm

Postby cguenther » Thu Aug 19, 2010 9:34 pm

hi,

im still waiting for any reply or update from martin hill. until now: nothing new. maybe it would help, if more people could express their interest directly to mhill@race...

best regards
carsten

olie05
Posts: 3
Joined: Wed Jun 30, 2010 7:08 pm

Postby olie05 » Wed Sep 22, 2010 8:08 pm

I'm interested in any updates on this.

cguenther
Posts: 36
Joined: Sun Jan 25, 2009 11:12 pm

Postby cguenther » Fri Sep 24, 2010 7:37 am

Hi olie05,

"im still waiting for any reply or update from martin hill. until now: nothing new. maybe it would help, if more people could express their interest directly to mhill@race... "

absolutely nothing new... i contacted lorne on this, but he directs me to martin, who is responsible for any research and improvement.

however, i got the feeling, that martin is not a "fan" of the megasquirt-ECU, not because they are'nt good, but he seems to have problems with the kind of development-speed and different branches of the hardware/firmware.

however, the communication-specs of the discussed MSII-hardware have'nt changed ever, so he has wrong/missing informations about this.

please: all concerned - mail to lorne@race-technology.com and mhill@race-technology.com and ask for progress! they already did some advertising concerning the availability of the megasquirt ecu-interface, however, i cannot confirm that the hardware is working. i will do immediately, if i got a new firmware and can test it on the car.

(actual problem is, that the car does not start, if the ecu-adapter is connected to the ecu. it somehow seems to block the ecu from working)

best regards
carsten


Return to “Pre-sales product questions”

Who is online

Users browsing this forum: No registered users and 3 guests